Commit ed589808 authored by Aleksei German's avatar Aleksei German
Browse files

Washing Machine Demo: updated CmakeLists

parent 0d6228e4
......@@ -6,14 +6,17 @@ find_package(Qul)
if (Qul_VERSION VERSION_GREATER_EQUAL "1.7")
qul_add_target(washingMachineUI)
set_property(TARGET washingMachineUI APPEND PROPERTY QUL_FONTS_DIR "${CMAKE_CURRENT_SOURCE_DIR}/fonts")
elseif (Qul_VERSION VERSION_EQUAL "1.6")
add_executable(washingMachineUI)
set(QUL_FONTS_DIR "${CMAKE_CURRENT_SOURCE_DIR}/fonts,${QUL_FONTS_DIR}")
target_link_libraries(washingMachineUI
Qul::QuickUltralite
Qul::QuickUltralitePlatform)
elseif (Qul_VERSION VERSION_LESS "1.6")
message(FATAL_ERROR "QUL versions below 1.6 are not supported in this project.")
endif()
set_property(TARGET washingMachineUI APPEND PROPERTY QUL_FONTS_DIR "${CMAKE_CURRENT_SOURCE_DIR}/fonts")
file(GLOB_RECURSE imgSources "*.png")
if(imgSources)
qul_add_resource(washingMachineUI FILES ${imgSources})
......@@ -22,17 +25,9 @@ endif()
file(GLOB_RECURSE qmlSources "*.qml")
qul_target_qml_sources(washingMachineUI ${qmlSources})
if(Qul_VERSION VERSION_GREATER_EQUAL "1.7")
target_link_libraries(washingMachineUI
Qul::QuickUltraliteTimeline
Qul::QuickUltraliteControlsStyleDefault)
else()
target_link_libraries(washingMachineUI
Qul::QuickUltralite
Qul::QuickUltralitePlatform
Qul::QuickUltraliteTimeline
Qul::QuickUltraliteControlsStyleDefault)
endif()
target_link_libraries(washingMachineUI
Qul::QuickUltraliteTimeline
Qul::QuickUltraliteControlsStyleDefault)
app_target_setup_os(washingMachineUI)
app_target_default_main(washingMachineUI washingMachineUI)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment