qtcreator.pro 524 Bytes
Newer Older
1 2 3 4 5 6 7
#version check qt
TOO_OLD_LIST=$$find(QT_VERSION, ^4\.[0-4])
count(TOO_OLD_LIST, 1) {
    message("Cannot build the Qt Creator with a Qt version that old:" $$QT_VERSION)
    error("Use at least Qt 4.5.")
}

Daniel Molkentin's avatar
Daniel Molkentin committed
8
include(doc/doc.pri)
9

con's avatar
con committed
10 11 12 13
TEMPLATE  = subdirs
CONFIG   += ordered

SUBDIRS = src
14 15 16 17 18 19 20 21

# for Qt Creator translations
QTC_BUILD_ROOT = $$PWD
QTC_INSTALL_TRANSLATIONS = $$PWD/translations

include(translations/translations.pri)
translations.path = $$QTC_INSTALL_TRANSLATIONS
translations.files = $$QTC_INSTALL_TRANSLATIONS/*.qm