Commit 0118bc29 authored by Alessandro Portale's avatar Alessandro Portale

Qt Quick Application Wizards: Add Qt 5.6

...also for qmake based projects

Change-Id: Ib8cab74a8b2249a13175593b27f228b4c7bc0052
Reviewed-by: default avatarEike Ziller <eike.ziller@theqtcompany.com>
Reviewed-by: default avatarTobias Hunger <tobias.hunger@theqtcompany.com>
parent b7eafe95
......@@ -43,6 +43,14 @@
"index": 2,
"items":
[
{
"trKey": "Qt 5.6",
"value":
"{
'qtQuickVersion': '2.6',
'qtQuickWindowVersion': '2.2'
}"
},
{
"trKey": "Qt 5.5",
"value":
......
......@@ -45,6 +45,16 @@
"index": 2,
"items":
[
{
"trKey": "Qt 5.6",
"value":
"{
'qtQuickVersion': '2.6',
'qtQuickControlsVersion': '1.5',
'qtQuickDialogsVersion': '1.2',
'qtQuickLayoutsVersion': '1.3'
}"
},
{
"trKey": "Qt 5.5",
"value":
......
......@@ -429,6 +429,12 @@ FeatureSet BaseQtVersion::availableFeatures() const
if (qtVersion().matches(5, 5))
return features;
features |= FeatureSet::versionedFeatures(Constants::FEATURE_QT_QUICK_PREFIX, 2, 6);
features |= FeatureSet::versionedFeatures(Constants::FEATURE_QT_QUICK_CONTROLS_PREFIX, 1, 5);
if (qtVersion().matches(5, 6))
return features;
return features;
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment