Commit 154b3e52 authored by Eike Ziller's avatar Eike Ziller
Browse files

AndroidManifestEditor: Initialize SDK versions when setting up UI



Instead of initializing it when opening the file, which has nothing to do
with it.

Change-Id: I5270d424c26dde7a66c0916281f718f779b1b2ac
Reviewed-by: default avatarDaniel Teske <daniel.teske@theqtcompany.com>
parent ea859787
......@@ -202,6 +202,8 @@ void AndroidManifestEditorWidget::initializePage()
packageGroupBox->setLayout(formLayout);
updateSdkVersions();
connect(m_packageNameLineEdit, SIGNAL(textEdited(QString)),
this, SLOT(setPackageName()));
connect(m_versionCode, SIGNAL(valueChanged(int)),
......@@ -503,7 +505,6 @@ void AndroidManifestEditorWidget::updateTargetComboBox()
bool AndroidManifestEditorWidget::open(QString *errorString, const QString &fileName, const QString &realFileName)
{
bool result = m_textEditorWidget->open(errorString, fileName, realFileName);
updateSdkVersions();
updateAfterFileLoad(result);
return result;
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment