Commit 2baa1f8b authored by hjk's avatar hjk Committed by Eike Ziller

Bump required Qt version to 5.5

Change-Id: I4f152bde842c20b0dade863ffea118fe32322c5b
Reviewed-by: default avatarChristian Kandeler <christian.kandeler@theqtcompany.com>
Reviewed-by: default avatarEike Ziller <eike.ziller@theqtcompany.com>
parent ea0c2377
......@@ -10,13 +10,13 @@ Windows XP SP3 or later
(K)Ubuntu Linux 11.10 (32-bit and 64-bit) or later
Mac OS X 10.7 or later
Building the sources requires Qt 5.4.0 or later.
Building the sources requires Qt 5.5.0 or later.
## Compiling Qt Creator
Prerequisites:
* Qt 5.4.0 or later
* Qt 5.5.0 or later
* On Windows:
* ActiveState Active Perl
* MinGW with g++ 4.7 or Visual Studio 2013 Update 2 or later
......@@ -58,7 +58,7 @@ For detailed information on the supported compilers, see
for example, `c:\work`. If you plan to use MinGW and Microsoft Visual
Studio simultaneously or mix different Qt versions, we recommend
creating a directory structure which reflects that. For example:
`C:\work\qt5.4.1-vs12, C:\work\qt5.4.1-mingw`.
`C:\work\qt5.5.1-vs12, C:\work\qt5.5.1-mingw`.
4. Download and install Perl from <https://www.activestate.com/activeperl>
and check that perl.exe is added to the path. Run `perl -v` to verify
......
......@@ -10,7 +10,7 @@ QtcProduct {
property var pluginRecommends: []
property var pluginTestDepends: []
property string minimumQtVersion: "5.4.0"
property string minimumQtVersion: "5.5.0"
condition: QtcFunctions.versionIsAtLeast(Qt.core.version, minimumQtVersion)
targetName: QtcFunctions.qtLibraryName(qbs, name)
......
include(qtcreator.pri)
#version check qt
!minQtVersion(5, 4, 0) {
!minQtVersion(5, 5, 0) {
message("Cannot build Qt Creator with Qt version $${QT_VERSION}.")
error("Use at least Qt 5.4.0.")
error("Use at least Qt 5.5.0.")
}
include(doc/doc.pri)
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment