Commit 5147aa02 authored by con's avatar con Committed by Eike Ziller

Make it possible to select Qt version on Mac OS.

Need to work around QTBUG-7739 that prohibits filters that don't start
with *

Change-Id: Ia984b25903abab125b403b53b5f3fe70ac9c54d4
Reviewed-on: http://codereview.qt.nokia.com/482Reviewed-by: default avatarQt Sanity Bot <qt_sanity_bot@ovi.com>
Reviewed-by: default avatarDaniel Teske <daniel.teske@nokia.com>
parent 7c11374f
......@@ -441,9 +441,13 @@ static QString filterForQmakeFileDialog()
{
QString filter("qmake (");
foreach (const QString &s, Utils::BuildableHelperLibrary::possibleQMakeCommands()) {
filter += s + " ";
#ifdef Q_WS_MAC
// work around QTBUG-7739 that prohibits filters that don't start with *
filter += QLatin1Char('*');
#endif
filter += s + QLatin1Char(' ');
}
filter += ")";
filter += QLatin1Char(')');
return filter;
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment