Commit 613a87cb authored by Marco Bubke's avatar Marco Bubke
Browse files

QmlDesigner: Test if declarative module exists to build qmlpuppet



Change-Id: I6aebcbcf77d95f03a85fc12fc3855ca95b9ba3ce
Reviewed-by: default avatarThomas Hartmann <Thomas.Hartmann@digia.com>
parent 18bff6f7
......@@ -4,8 +4,10 @@ include(../../../qtcreator.pri)
include(../../private_headers.pri)
greaterThan(QT_MAJOR_VERSION, 4) {
QT += declarative-private core-private
SUBDIRS += qmlpuppet
qtHaveModule(declarative) {
QT += declarative-private core-private
SUBDIRS += qmlpuppet
}
} else {
exists($${QT_PRIVATE_HEADERS}/QtDeclarative/private/qdeclarativecontext_p.h) {
minQtVersion(4, 7, 1) {
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment