Commit b7bc044b authored by Nikolai Kosjar's avatar Nikolai Kosjar

Clang: Require llvm/libclang 3.6.2 as minimum version

...since we had crash issues on OS X with 3.6.0/3.6.1.

Released packages are already shipped with 3.6.2.

Change-Id: I364288d5c7dc32beacbbdbc231c2be4e6a6818bf
Reviewed-by: default avatarMarco Bubke <marco.bubke@theqtcompany.com>
parent cacd014d
......@@ -96,7 +96,7 @@
\list 1
\li Acquire Clang 3.6.0 or higher in one of the following ways:
\li Acquire Clang 3.6.2 or higher in one of the following ways:
\list
......
var File = loadExtension("qbs.File")
var MinimumLLVMVersion = "3.6.0"
var MinimumLLVMVersion = "3.6.2"
function isSuitableLLVMConfig(llvmConfigCandidate, qtcFunctions, processOutputReader)
{
......
......@@ -6,15 +6,21 @@ isEmpty(LLVM_INSTALL_DIR): error("No LLVM_INSTALL_DIR provided")
defineReplace(extractVersion) { return($$replace(1, ^(\\d+\\.\\d+\\.\\d+)$, \\1)) }
defineReplace(extractMajorVersion) { return($$replace(1, ^(\\d+)\\.\\d+\\.\\d+$, \\1)) }
defineReplace(extractMinorVersion) { return($$replace(1, ^\\d+\\.(\\d+)\\.\\d+$, \\1)) }
defineReplace(extractPatchVersion) { return($$replace(1, ^\\d+\\.\\d+\\.(\\d+)$, \\1)) }
defineTest(versionIsAtLeast) {
actual_major_version = $$extractMajorVersion($$1)
actual_minor_version = $$extractMinorVersion($$1)
actual_patch_version = $$extractPatchVersion($$1)
required_min_major_version = $$2
required_min_minor_version = $$3
required_min_patch_version = $$4
isEqual(actual_major_version, $$required_min_major_version) {
isEqual(actual_minor_version, $$required_min_minor_version): return(true)
isEqual(actual_minor_version, $$required_min_minor_version) {
isEqual(actual_patch_version, $$required_min_patch_version): return(true)
greaterThan(actual_patch_version, $$required_min_patch_version): return(true)
}
greaterThan(actual_minor_version, $$required_min_minor_version): return(true)
}
greaterThan(actual_major_version, $$required_min_major_version): return(true)
......@@ -97,6 +103,6 @@ unix {
}
isEmpty(LLVM_VERSION): error("Cannot determine clang version at $$LLVM_INSTALL_DIR")
!versionIsAtLeast($$LLVM_VERSION, 3, 6): {
error("LLVM/Clang version >= 3.6.0 required, version provided: $$LLVM_VERSION")
!versionIsAtLeast($$LLVM_VERSION, 3, 6, 2): {
error("LLVM/Clang version >= 3.6.2 required, version provided: $$LLVM_VERSION")
}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment