Commit bef8f58f authored by Robert Loehning's avatar Robert Loehning Committed by Robert Löhning
Browse files

Squish: Updated calls to iterateBuildConfigs



Change-Id: Idca2d311399194b455e211fb72d1fcf810cbb624
Reviewed-by: default avatarChristian Stenger <christian.stenger@nokia.com>
parent 3f6eed50
...@@ -15,7 +15,7 @@ def verifyBuildAndRun(): ...@@ -15,7 +15,7 @@ def verifyBuildAndRun():
# pick version 4.7.4 and then run project for debug and release # pick version 4.7.4 and then run project for debug and release
def pickVersion474runVerify(): def pickVersion474runVerify():
availableConfigs = iterateBuildConfigs(1, 0, ".*4.7.4.*") availableConfigs = iterateBuildConfigs(1, 0)
if not availableConfigs: if not availableConfigs:
test.fatal("Haven't found needed Qt version (Qt 4.7.4), quitting") test.fatal("Haven't found needed Qt version (Qt 4.7.4), quitting")
invokeMenuItem("File", "Save All") invokeMenuItem("File", "Save All")
......
...@@ -14,7 +14,7 @@ def main(): ...@@ -14,7 +14,7 @@ def main():
# open example project # open example project
openQmakeProject(examplePath) openQmakeProject(examplePath)
# build and wait until finished - on all (except Qt 4.7.0 (would fail)) build configurations # build and wait until finished - on all (except Qt 4.7.0 (would fail)) build configurations
availableConfigs = iterateBuildConfigs(1, 0, "(?!.*4\.7\.0.*)") availableConfigs = iterateBuildConfigs(1, 0)
if not availableConfigs: if not availableConfigs:
test.fatal("Haven't found a suitable Qt version (anything except Qt 4.7.0) - leaving without building.") test.fatal("Haven't found a suitable Qt version (anything except Qt 4.7.0) - leaving without building.")
for config in availableConfigs: for config in availableConfigs:
......
...@@ -7,7 +7,7 @@ def main(): ...@@ -7,7 +7,7 @@ def main():
# create qt quick application # create qt quick application
createNewQtQuickApplication(tempDir(), "SampleApp") createNewQtQuickApplication(tempDir(), "SampleApp")
# build it - on all (except Qt 4.7.0 (would fail)) build configurations # build it - on all (except Qt 4.7.0 (would fail)) build configurations
availableConfigs = iterateBuildConfigs(1, 0, "(?!.*4\.7\.0.*)") availableConfigs = iterateBuildConfigs(1, 0)
if not availableConfigs: if not availableConfigs:
test.fatal("Haven't found a suitable Qt version (anything except Qt 4.7.0) - leaving without building.") test.fatal("Haven't found a suitable Qt version (anything except Qt 4.7.0) - leaving without building.")
for config in availableConfigs: for config in availableConfigs:
......
...@@ -17,7 +17,7 @@ def main(): ...@@ -17,7 +17,7 @@ def main():
# save all # save all
invokeMenuItem("File", "Save All") invokeMenuItem("File", "Save All")
# build it - on all (except Qt 4.7.0 (would fail)) build configurations # build it - on all (except Qt 4.7.0 (would fail)) build configurations
availableConfigs = iterateBuildConfigs(1, 0, "(?!.*4\.7\.0.*)") availableConfigs = iterateBuildConfigs(1, 0)
if not availableConfigs: if not availableConfigs:
test.fatal("Haven't found a suitable Qt version (anything except Qt 4.7.0) - leaving without building.") test.fatal("Haven't found a suitable Qt version (anything except Qt 4.7.0) - leaving without building.")
for config in availableConfigs: for config in availableConfigs:
......
...@@ -34,7 +34,7 @@ def main(): ...@@ -34,7 +34,7 @@ def main():
if result: if result:
expectedBreakpointsOrder = [{"main.cpp":9}, {"main.qml":14}] expectedBreakpointsOrder = [{"main.cpp":9}, {"main.qml":14}]
# Only use 4.7.4 to work around QTBUG-25187 # Only use 4.7.4 to work around QTBUG-25187
availableConfigs = iterateBuildConfigs(1, 0, ".*4\.7\.4.*$(?<![Rr]elease)") availableConfigs = iterateBuildConfigs(1, 0, "Debug")
if not availableConfigs: if not availableConfigs:
test.fatal("Haven't found a suitable Qt version (need Qt 4.7.4) - leaving without debugging.") test.fatal("Haven't found a suitable Qt version (need Qt 4.7.4) - leaving without debugging.")
for config in availableConfigs: for config in availableConfigs:
......
...@@ -21,7 +21,7 @@ def main(): ...@@ -21,7 +21,7 @@ def main():
fancyToolButton = waitForObject(":*Qt Creator_Core::Internal::FancyToolButton") fancyToolButton = waitForObject(":*Qt Creator_Core::Internal::FancyToolButton")
qtVerPattern = re.compile("\d\.\d(\.\d+)?") qtVerPattern = re.compile("\d\.\d(\.\d+)?")
availableConfigs = iterateBuildConfigs(1, 0, "(Desktop )?Qt.*Release") availableConfigs = iterateBuildConfigs(1, 0, "Release")
if not availableConfigs: if not availableConfigs:
test.fatal("Haven't found a suitable Qt version (need Release build) - leaving without building.") test.fatal("Haven't found a suitable Qt version (need Release build) - leaving without building.")
for config in availableConfigs: for config in availableConfigs:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment