Commit e0ffb2f6 authored by Robert Loehning's avatar Robert Loehning Committed by Robert Löhning
Browse files

Squish: Updated tst_build_speedcrunch



Change-Id: Ie5228fec880b3c9c1d5c24799973107677b724f3
Reviewed-by: default avatarChristian Stenger <christian.stenger@nokia.com>
parent 02d3fc90
......@@ -20,20 +20,10 @@ def main():
fancyToolButton = waitForObject(":*Qt Creator_Core::Internal::FancyToolButton")
qtVerPattern = re.compile("\d\.\d(\.\d+)?")
availableConfigs = iterateBuildConfigs(1, 0, "Release")
if not availableConfigs:
test.fatal("Haven't found a suitable Qt version (need Release build) - leaving without building.")
for config in availableConfigs:
qtVersion = qtVerPattern.search(config)
if qtVersion:
qtVersion = qtVersion.group()
if qtVersion >= "4.8":
test.log("Skipping config %s - this project needs Qt <= 4.7.x (got %s)" % (config, qtVersion))
continue
else:
test.warning("Could not determine Qt version for config '%s' - skipping..." % config)
continue
selectBuildConfig(1, 0, config)
buildConfig = buildConfigFromFancyToolButton(fancyToolButton)
if buildConfig != config:
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment