Doc: Update docs after Ant support was removed

Gradle is now used for building APKs.

Change-Id: I9ccecac39b70ada5ef1b63a7311ad9187ba0d6b9
Reviewed-by: Alessandro Portale's avatarAlessandro Portale <alessandro.portale@qt.io>
parent b1a8743f
......@@ -59,12 +59,11 @@
\li \l{http://www.gradle.org}{Gradle} for building application packages
for Android devices (APK). Gradle is delivered with Qt 5.9, and
later.
later. Because Gradle scripts are not delivered with Android SDK
Tools since version 26.0.0, they are delivered with Qt 5.9 and
5.6.3.
\note Using Ant to build APKs is still possible when developing with
Qt 5.8 or earlier together with Android SDK tools versions 25.2.5 or
earlier, but Ant support has been deprecated since \QC 4.3 and will
be removed in a future version.
\note Using Ant to build APKs is no longer supported.
\li A tool chain for building applications for Android devices provided
by the \l{http://developer.android.com/tools/sdk/ndk/index.html}
......@@ -151,21 +150,6 @@
check box to allow \QC to create the kits for you. \QC displays a
warning if it cannot find a suitable Qt version.
\li Select the tool to use for building application packages:
\list
\li To use Gradle, select the \uicontrol {Use Gradle instead of Ant}
check box.
\li To use Ant, add the path to the Ant executable in the
\uicontrol {Ant executable} field.
\note Ant support has been deprecated since \QC 4.3. We
recommend that you use Gradle instead.
\endlist
\li Select \uicontrol File > \uicontrol {New File or Project} > \uicontrol Application >
\uicontrol {Qt Quick Application} > \uicontrol Choose, and
follow the instructions of the wizard. For more information, see
......
......@@ -53,10 +53,10 @@
set up the development environment for the device platform and configure a
connection between \QC and the mobile device.
To develop for Android devices, you must download and install
the latest Android NDK and SDK, and update the SDK to get the API and tools
needed for development. In addition, you must install the
Java SE Development Kit (JDK) and Apache Ant. After you have installed all
To develop for Android devices, you must download and install the latest
Android NDK and SDK Tools, and then update or install the tools and packages
needed for development. In addition, you must install the Java SE
Development Kit (JDK). After you have installed all
these tools, you must specify the paths to them in \QC.
For detailed instructions, see \l{Qt for Android} and
\l{Connecting Android Devices}.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment