Commit 38ab088c authored by Kai Koehne's avatar Kai Koehne
Browse files

plugins: Simplify checks for declarative



We can expect people with Qt 5.1 to also have QtQuick.

Change-Id: I84b0323c6ea11b46f3ee41c0bbdc5f059643f208
Reviewed-by: default avatarhjk <hjk121@nokiamail.com>
parent 3ae8d6b3
......@@ -31,6 +31,7 @@ SUBDIRS = \
resourceeditor \
genericprojectmanager \
qmljseditor \
qmlprojectmanager \
glsleditor \
pythoneditor \
mercurial \
......@@ -62,23 +63,16 @@ isEmpty(IDE_PACKAGE_MODE) {
updateinfo
}
contains(QT_CONFIG, declarative)|!isEmpty(QT.declarative.name) {
minQtVersion(5, 1, 0) {
SUBDIRS += \
qmlprojectmanager
greaterThan(QT_MAJOR_VERSION, 4):greaterThan(QT_MINOR_VERSION, 0) {
SUBDIRS += \
qmldesigner \
qmlprofiler \
welcome
} else {
warning("QmlDesigner plugin has been disabled.")
warning("QmlProfiler plugin has been disabled.")
warning("Welcome plugin has been disabled.")
warning("These plugins need at least Qt 5.1.")
}
qmldesigner \
qmlprofiler \
welcome
} else {
warning("QmlProjectManager, QmlProfiler and QmlDesigner plugins have been disabled: The plugins require QtDeclarative")
warning("QmlDesigner plugin has been disabled.")
warning("QmlProfiler plugin has been disabled.")
warning("Welcome plugin has been disabled.")
warning("These plugins need at least Qt 5.1.")
}
for(p, SUBDIRS) {
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment