Commit 3af3fe7a authored by Sergio Ahumada's avatar Sergio Ahumada Committed by Sergio Ahumada

Replace old qt-project.org wiki with wiki.qt.io

Change-Id: Ie7518d57b62e3f0b9dc6c559fe4a8f5b0212bb43
Reviewed-by: default avatarLeena Miettinen <riitta-leena.miettinen@theqtcompany.com>
parent b8db05c3
......@@ -43,7 +43,7 @@ versions of Qt and Qt Creator on Windows. Alternatively, to avoid having to
compile Qt yourself, you can use one of the versions of Qt shipped with the Qt
SDK (release builds of Qt using MinGW and Visual C++ 2010 or later).
For detailed information on the supported compilers, see
http://qt-project.org/wiki/Building_Qt_5_from_Git .
http://wiki.qt.io/Building_Qt_5_from_Git .
1. Decide which compiler to use: MinGW or Microsoft Visual Studio. If you
plan to contribute to Qt Creator, you should compile your changes with
......@@ -75,7 +75,7 @@ http://qt-project.org/wiki/Building_Qt_5_from_Git .
directory.
7. Install a compiler:
- For a MinGW toolchain for Qt, see http://qt-project.org/wiki/MinGW .
- For a MinGW toolchain for Qt, see http://wiki.qt.io/MinGW .
- For Microsoft Visual C++, install the Windows SDK and the "Debugging
Tools for Windows" from the SDK image. We strongly recommend using the
......@@ -122,7 +122,7 @@ http://qt-project.org/wiki/Building_Qt_5_from_Git .
You have to remove it from the path.
10. You are now ready to configure and build Qt and Qt Creator.
Please see http://qt-project.org/wiki/Building_Qt_5_from_Git for
Please see http://wiki.qt.io/Building_Qt_5_from_Git for
recommended configure-options for Qt 5.
To use MinGW, open the the shell prompt and enter:
......
......@@ -23,6 +23,6 @@
<screenshots>
<screenshot type="default" width="800" height="600">http://qt-project.org/uploads/image_upload/qtcreator-edit-mode.png</screenshot>
</screenshots>
<url type="homepage">https://qt-project.org/wiki/Category:Tools::QtCreator</url>
<url type="homepage">https://wiki.qt.io/Category:Tools::QtCreator</url>
<project_group>Qt</project_group>
</application>
......@@ -131,7 +131,7 @@
\section1 Writing Text
Follow the guidelines for
\l{http://qt-project.org/wiki/Writing_Qt_Documentation}
\l{http://wiki.qt.io/Writing_Qt_Documentation}
{writing Qt documentation}.
The documentation must be grammatically correct English and use the standard
......
......@@ -181,7 +181,7 @@
versions of MinGW. On most Linux distributions the GDB
builds shipped with the system are sufficient. You can
also build your own. Follow the instructions in
\l{http://qt-project.org/wiki/QtCreatorBuildGdb}
\l{http://wiki.qt.io/QtCreator_Build_Gdb}
{Building GDB}.
Builds of GDB shipped with Xcode on OS X are no longer
supported.
......
......@@ -191,7 +191,7 @@
installed when you install \QC and \QSDK. On OS X, GDB is no longer
officially supported. To build your own Python-enabled GDB, follow the
instructions in
\l{http://qt-project.org/wiki/QtCreatorBuildGdb}{Building GDB}.
\l{http://wiki.qt.io/QtCreator_Build_Gdb}{Building GDB}.
You must use Python version 2.6 or 2.7.
......
......@@ -41,7 +41,7 @@
\row
\li Learn more about Qt
\li \l{http://qt-project.org/wiki/developer-guides}
\li \l{http://wiki.qt.io/developer_guides}
{Qt Developer Guides}
\row
......
......@@ -84,7 +84,7 @@
filter, so you need to set this filter in the top-right corner of the
\uicontrol {New} dialog to enable those templates.
\note Currently, the BlackBerry 10 devices and Simulator have Qt 4.8 libraries preinstalled. To use Qt 5 features, you must compile the Qt libraries for BlackBerry 10 yourself. For more information, see \l {http://qt-project.org/wiki/Building-Qt5-for-Blackberry}{http://qt-p roject.org/wiki/Building-Qt5-for-Blackberry}.
\note Currently, the BlackBerry 10 devices and Simulator have Qt 4.8 libraries preinstalled. To use Qt 5 features, you must compile the Qt libraries for BlackBerry 10 yourself. For more information, see \l {http://wiki.qt.io/Building_Qt5_for_Blackberry}{Building Qt5 for BlackBerry}.
For more details please refer to the Qt-Project wiki page: \l {http://qt-project.org/wiki/BlackBerry} {http://qt-project.org/wiki/BlackBerry}.
For more details please refer to the Qt-Project wiki page: \l {http://wiki.qt.io/BlackBerry}{Qt for BlackBerry}.
*/
......@@ -120,5 +120,5 @@
\include qnx/creator-key-management-qnx.qdocinc
For more details please refer to the Qt-Project wiki page: \l {http://qt-project.org/wiki/BlackBerry} {http://qt-project.org/wiki/BlackBerry}.
For more details please refer to the Qt-Project wiki page: \l {http://wiki.qt.io/BlackBerry}{Qt for BlackBerry}.
*/
......@@ -55,7 +55,7 @@ using namespace Utils;
namespace Debugger {
namespace Internal {
static const char debuggingToolsWikiLinkC[] = "http://qt-project.org/wiki/Qt_Creator_Windows_Debugging";
static const char debuggingToolsWikiLinkC[] = "http://wiki.qt.io/Qt_Creator_Windows_Debugging";
// -----------------------------------------------------------------------
// DebuggerItemConfigWidget
......
......@@ -139,7 +139,7 @@ ProjectExplorer::RunControl *BlackBerryRunControlFactory::create(ProjectExplorer
if (qtVer && qtVer->qtVersion() <= QtSupport::QtVersionNumber(4, 8, 6))
Core::MessageManager::write(tr("Target Qt version (%1) might not support QML profiling. "
"Cascades applications are not affected and should work as expected. "
"For more info see http://qt-project.org/wiki/Qt-Creator-with-BlackBerry-10")
"For more info see http://wiki.qt.io/Qt_Creator_with_BlackBerry_10")
.arg(qtVer->qtVersionString()), Core::MessageManager::Flash
);
......
......@@ -128,7 +128,7 @@ const char QNX_BLACKBERRY_DEFAULT_DEPLOY_QT_BASEPATH[] = "/accounts/devuser/";
const char QNX_OK_ICON[] = ":/qnx/images/ok.png";
const char QNX_BLACKBERRY_SETUP_URL[] = "http://qt-project.org/wiki/Qt-Creator-with-BlackBerry-10";
const char QNX_BLACKBERRY_SETUP_URL[] = "http://wiki.qt.io/Qt_Creator_with_BlackBerry_10";
const char QNX_LEGACY_KEYS_URL[] = "https://developer.blackberry.com/native/documentation/core"
"/com.qnx.doc.ide.userguide/topic/signing_and_publishing.html";
const char QNX_REGISTER_KEYS_URL[] = "https://www.blackberry.com/SignedKeys/codesigning.html";
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment