Commit c652d3ba authored by Kai Koehne's avatar Kai Koehne

QtOptionsPage: Don't build qml helpers for 4.8

They're not required any more.

Change-Id: If55d835600ea0ddf6b6b54f8fdd88e2025fc17be
Reviewed-by: default avatarChristian Kamm <christian.d.kamm@nokia.com>
Reviewed-by: default avatarDaniel Teske <daniel.teske@nokia.com>
parent e2b911b4
......@@ -73,6 +73,11 @@ bool QmlDebuggingLibrary::canBuild(const BaseQtVersion *qtVersion, QString *reas
*reason = QCoreApplication::translate("Qt4ProjectManager::QmlDebuggingLibrary", "Only available for Qt 4.7.1 or newer.");
return false;
}
if (qtVersion->qtVersion() >= QtVersionNumber(4, 8, 0)) {
if (reason)
*reason = QCoreApplication::translate("Qt4ProjectManager::QmlDebuggingLibrary", "Not needed.");
return false;
}
return true;
}
......
......@@ -209,6 +209,12 @@ bool QmlDumpTool::canBuild(const BaseQtVersion *qtVersion, QString *reason)
*reason = QCoreApplication::translate("Qt4ProjectManager::QmlDumpTool", "Only available for Qt 4.7.1 or newer.");
return false;
}
if (qtVersion->qtVersion() >= QtVersionNumber(4, 8, 0)) {
if (reason)
*reason = QCoreApplication::translate("Qt4ProjectManager::QmlDumpTool", "Not needed.");
return false;
}
if (!hasPrivateHeaders(installHeaders)) {
if (reason)
......
......@@ -68,6 +68,11 @@ bool QmlObserverTool::canBuild(const BaseQtVersion *qtVersion, QString *reason)
*reason = QCoreApplication::translate("Qt4ProjectManager::QmlObserverTool", "Only available for Qt 4.7.1 or newer.");
return false;
}
if (qtVersion->qtVersion() >= QtVersionNumber(4, 8, 0)) {
if (reason)
*reason = QCoreApplication::translate("Qt4ProjectManager::QmlObserverTool", "Not needed.");
return false;
}
return true;
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment