Skip to content
Snippets Groups Projects
  • Samuli Piippo's avatar
    08875b84
    Merge remote-tracking branch 'origin/stable' into dizzy · 08875b84
    Samuli Piippo authored
    * origin/stable:
      Update checksum for Noto fonts release 1.002
      toradex: add support for u-boot update on colibri vf
      Update Colibri-VF recpies to use latest meta-toradex (V2.3)
      Fix Linux Kernel 3.18 build with Colibri-VF
      scripts: use correct upload path
      toradex: update toradex meta layer
      Change mirror of hunspell dictionaries
      Install CJK fonts on eLinux image
    
    Conflicts:
    	conf/distro/include/colibri-vf.conf
    	meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-Update-default-args-for-apalis-imx6.patch
    	recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
    	scripts/manifest.xml
    	scripts/upload.sh
    
    Change-Id: I38f7fc045264d13e3a1c6c4afd4e7355ac8f56c9
    08875b84
    History
    Merge remote-tracking branch 'origin/stable' into dizzy
    Samuli Piippo authored
    * origin/stable:
      Update checksum for Noto fonts release 1.002
      toradex: add support for u-boot update on colibri vf
      Update Colibri-VF recpies to use latest meta-toradex (V2.3)
      Fix Linux Kernel 3.18 build with Colibri-VF
      scripts: use correct upload path
      toradex: update toradex meta layer
      Change mirror of hunspell dictionaries
      Install CJK fonts on eLinux image
    
    Conflicts:
    	conf/distro/include/colibri-vf.conf
    	meta-toradex-extras/recipes/u-boot/u-boot-toradex-fsl/0001-Update-default-args-for-apalis-imx6.patch
    	recipes/packagegroup/packagegroup-b2qt-embedded-base.bb
    	scripts/manifest.xml
    	scripts/upload.sh
    
    Change-Id: I38f7fc045264d13e3a1c6c4afd4e7355ac8f56c9
packagegroup-b2qt-embedded-base.bb 1.55 KiB
#############################################################################
##
## Copyright (C) 2014 Digia Plc and/or its subsidiary(-ies).
##
## This file is part of the Qt Enterprise Embedded Scripts of the Qt
## framework.
##
## $QT_BEGIN_LICENSE$
## Commercial License Usage Only
## Licensees holding valid commercial Qt license agreements with Digia
## with an appropriate addendum covering the Qt Enterprise Embedded Scripts,
## may use this file in accordance with the terms contained in said license
## agreement.
##
## For further information use the contact form at
## http://www.qt.io/contact-us.
##
##
## $QT_END_LICENSE$
##
#############################################################################

DESCRIPTION = "Packagegroup for B2Qt embedded Linux image"
LICENSE = "CLOSED"
PR = "r0"

inherit packagegroup

RDEPENDS_${PN} = "\
        kernel-modules \
        adbd \
        psplash \
        openssh-sftp-server \
        openssl \
        openssl-misc \
        libpng \
        tiff \
        libxslt \
        icu \
        freetype \
        fontconfig \
        liberation-fonts \
        tslib \
        tslib-calibrate \
        alsa-utils-amixer \
        hunspell \
        ca-certificates \
        linux-firmware \
        ttf-devanagari \
        ttf-opensans \
        ttf-dejavu-common \
        ttf-dejavu-sans \
        dbus-session-init \
        otf-noto \
        libmysqlclient \
        libpq \
        ${@base_contains("DISTRO_FEATURES", "wayland", "wayland weston weston-examples", "", d)} \
        ${MACHINE_EXTRA_INSTALL} \
        "