-
Samuli Piippo authored
Add configuration to config.txt to enable both HDMI outputs. The KMS atomic API needs to be disabled as it fails with dual HDMI output. Taskk-number: QTBUG-82816 Change-Id: I1a9cc95eecd9fad253862da764f52bebb5cdd1df Reviewed-by:
Mikko Gronoff <mikko.gronoff@qt.io>
Samuli Piippo authoredAdd configuration to config.txt to enable both HDMI outputs. The KMS atomic API needs to be disabled as it fails with dual HDMI output. Taskk-number: QTBUG-82816 Change-Id: I1a9cc95eecd9fad253862da764f52bebb5cdd1df Reviewed-by:
Mikko Gronoff <mikko.gronoff@qt.io>
default-qt-envs.bbappend 1.44 KiB
############################################################################
##
## Copyright (C) 2019 The Qt Company Ltd.
## Contact: https://www.qt.io/licensing/
##
## This file is part of the Boot to Qt meta layer.
##
## $QT_BEGIN_LICENSE:GPL$
## Commercial License Usage
## Licensees holding valid commercial Qt licenses may use this file in
## accordance with the commercial license agreement provided with the
## Software or, alternatively, in accordance with the terms contained in
## a written agreement between you and The Qt Company. For licensing terms
## and conditions see https://www.qt.io/terms-conditions. For further
## information use the contact form at https://www.qt.io/contact-us.
##
## GNU General Public License Usage
## Alternatively, this file may be used under the terms of the GNU
## General Public License version 3 or (at your option) any later version
## approved by the KDE Free Qt Foundation. The licenses are as published by
## the Free Software Foundation and appearing in the file LICENSE.GPL3
## included in the packaging of this file. Please review the following
## information to ensure the GNU General Public License requirements will
## be met: https://www.gnu.org/licenses/gpl-3.0.html.
##
## $QT_END_LICENSE$
##
############################################################################
do_configure_append() {
echo "QT_QPA_EGLFS_FORCE888=1" >> ${WORKDIR}/defaults
echo "QT_QPA_EGLFS_KMS_ATOMIC=0" >> ${WORKDIR}/defaults
}