Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
M
Meta Boot2qt
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Shinichi Okada
Meta Boot2qt
Commits
637db7aa
Commit
637db7aa
authored
9 years ago
by
Samuli Piippo
Committed by
The Qt Project
9 years ago
Browse files
Options
Downloads
Plain Diff
Merge "Merge remote-tracking branch 'origin/dizzy' into dev" into refs/staging/dev
parents
506bad78
82e46748
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
meta-architech-extras/recipes/u-boot/u-boot-fslc_2013.10.bb
+2
-2
2 additions, 2 deletions
meta-architech-extras/recipes/u-boot/u-boot-fslc_2013.10.bb
meta-architech-extras/recipes/u-boot/u-boot.inc
+88
-0
88 additions, 0 deletions
meta-architech-extras/recipes/u-boot/u-boot.inc
with
90 additions
and
2 deletions
meta-architech-extras/recipes/u-boot/u-boot-fslc_2013.10.bb
+
2
−
2
View file @
637db7aa
require
recipes-bsp/u-boot/
u-boot.inc
require u-boot.inc
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=025bf9f768cbcb1a165dbe1a110babfb"
...
...
@@ -11,7 +11,7 @@ PROVIDES += "u-boot"
PV = "v2013.10"
SRCREV = "079e214888279518ce061c71238a74a0c3db2c28"
SRC_URI = "git://github.com/Freescale/u-boot-imx.git"
SRC_URI = "git://github.com/Freescale/u-boot-imx.git
;branch=patches-2013.10
"
S = "${WORKDIR}/git"
...
...
This diff is collapsed.
Click to expand it.
meta-architech-extras/recipes/u-boot/u-boot.inc
0 → 100644
+
88
−
0
View file @
637db7aa
DESCRIPTION
=
"U-Boot - the Universal Boot Loader"
HOMEPAGE
=
"http://www.denx.de/wiki/U-Boot/WebHome"
SECTION
=
"bootloaders"
PROVIDES
=
"virtual/bootloader"
inherit
uboot
-
config
deploy
EXTRA_OEMAKE
=
'CROSS_COMPILE=${TARGET_PREFIX} CC="${TARGET_PREFIX}gcc ${TOOLCHAIN_OPTIONS}"'
# Allow setting an additional version string that will be picked up by the
# u-boot build system and appended to the u-boot version. If the .scmversion
# file already exists it will not be overwritten.
UBOOT_LOCALVERSION
?=
""
# Some versions of u-boot use .bin and others use .img. By default use .bin
# but enable individual recipes to change this value.
UBOOT_SUFFIX
?=
"bin"
UBOOT_IMAGE
?=
"u-boot-${MACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
UBOOT_BINARY
?=
"u-boot.${UBOOT_SUFFIX}"
UBOOT_SYMLINK
?=
"u-boot-${MACHINE}.${UBOOT_SUFFIX}"
UBOOT_MAKE_TARGET
?=
"all"
# Some versions of u-boot build an SPL (Second Program Loader) image that
# should be packaged along with the u-boot binary as well as placed in the
# deploy directory. For those versions they can set the following variables
# to allow packaging the SPL.
SPL_BINARY
?=
""
SPL_IMAGE
?=
"${SPL_BINARY}-${MACHINE}-${PV}-${PR}"
SPL_SYMLINK
?=
"${SPL_BINARY}-${MACHINE}"
do_compile
()
{
if
[
"${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}"
=
"ld-is-gold"
]
;
then
sed
-
i
's/$(CROSS_COMPILE)ld$/$(CROSS_COMPILE)ld.bfd/g'
config
.
mk
fi
unset
LDFLAGS
unset
CFLAGS
unset
CPPFLAGS
if
[
!
-
e
$
{
B
}
/.
scmversion
-
a
!
-
e
$
{
S
}
/.
scmversion
]
then
echo
$
{
UBOOT_LOCALVERSION
}
>
$
{
B
}
/.
scmversion
echo
$
{
UBOOT_LOCALVERSION
}
>
$
{
S
}
/.
scmversion
fi
oe_runmake
$
{
UBOOT_MACHINE
}
oe_runmake
$
{
UBOOT_MAKE_TARGET
}
}
do_install
()
{
install
-
d
$
{
D
}
/
boot
install
$
{
S
}
/
$
{
UBOOT_BINARY
}
$
{
D
}
/
boot
/
$
{
UBOOT_IMAGE
}
ln
-
sf
$
{
UBOOT_IMAGE
}
$
{
D
}
/
boot
/
$
{
UBOOT_BINARY
}
if
[
-
e
$
{
WORKDIR
}
/
fw_env
.
config
]
;
then
install
-
d
$
{
D
}
$
{
sysconfdir
}
install
-
m
644
$
{
WORKDIR
}
/
fw_env
.
config
$
{
D
}
$
{
sysconfdir
}
/
fw_env
.
config
fi
if
[
"x${SPL_BINARY}"
!=
"x"
]
then
install
$
{
S
}
/
$
{
SPL_BINARY
}
$
{
D
}
/
boot
/
$
{
SPL_IMAGE
}
ln
-
sf
$
{
SPL_IMAGE
}
$
{
D
}
/
boot
/
$
{
SPL_BINARY
}
fi
}
FILES_
$
{
PN
}
=
"/boot ${sysconfdir}"
FILESPATH
=
.
"${FILE_DIRNAME}/u-boot-git/${MACHINE}:"
do_deploy
()
{
install
-
d
$
{
DEPLOYDIR
}
install
$
{
S
}
/
$
{
UBOOT_BINARY
}
$
{
DEPLOYDIR
}
/
$
{
UBOOT_IMAGE
}
cd
$
{
DEPLOYDIR
}
rm
-
f
$
{
UBOOT_BINARY
}
$
{
UBOOT_SYMLINK
}
ln
-
sf
$
{
UBOOT_IMAGE
}
$
{
UBOOT_SYMLINK
}
ln
-
sf
$
{
UBOOT_IMAGE
}
$
{
UBOOT_BINARY
}
if
[
"x${SPL_BINARY}"
!=
"x"
]
then
install
$
{
S
}
/
$
{
SPL_BINARY
}
$
{
DEPLOYDIR
}
/
$
{
SPL_IMAGE
}
rm
-
f
$
{
DEPLOYDIR
}
/
$
{
SPL_BINARY
}
$
{
DEPLOYDIR
}
/
$
{
SPL_SYMLINK
}
ln
-
sf
$
{
SPL_IMAGE
}
$
{
DEPLOYDIR
}
/
$
{
SPL_BINARY
}
ln
-
sf
$
{
SPL_IMAGE
}
$
{
DEPLOYDIR
}
/
$
{
SPL_SYMLINK
}
fi
}
addtask
deploy
before
do_build
after
do_compile
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment