Commit 7a722e2c authored by Oswald Buddenhagen's avatar Oswald Buddenhagen
Browse files

protect against "make ts" with too old linguist tools

... which i of course promptly managed to do. argh.
parent 98f04ed2
......@@ -14,7 +14,8 @@ LRELEASE = $$targetPath($$[QT_INSTALL_PREFIX]/bin/lrelease)
TS_FILES = $$prependAll(TRANSLATIONS, $$PWD/qtcreator_,.ts)
ts.commands = (cd $$IDE_SOURCE_TREE && $$LUPDATE src -ts $$TS_FILES)
contains(QT_VERSION, ^4\.[0-5]\..*):ts.commands = @echo This Qt version is too old for the ts target. Need Qt 4.6+.
else:ts.commands = (cd $$IDE_SOURCE_TREE && $$LUPDATE src -ts $$TS_FILES)
QMAKE_EXTRA_TARGETS += ts
contains(TEMPLATE, vc.*)|contains(TEMPLATE_PREFIX, vc):vcproj = 1
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment