Commit bc3a1ca2 authored by con's avatar con

Mac: Explicitly do a 10.5+ build if not doing a tiger compatible build.

Qt for some reason doesn't tell the tool chain to require 10.5 when
doing a cocoa build but on x86.
parent 9b115f4b
......@@ -102,6 +102,10 @@ macx {
contains(QT_CONFIG, ppc):CONFIG += ppc x86
copydata = 1
isEmpty(TIGER_COMPAT_MODE):TIGER_COMPAT_MODE=$$(QTC_TIGER_COMPAT)
isEmpty(TIGER_COMPAT_MODE) {
QMAKE_CXXFLAGS *= -mmacosx-version-min=10.5
QMAKE_LFLAGS *= -mmacosx-version-min=10.5
}
} else {
win32 {
contains(TEMPLATE, vc.*)|contains(TEMPLATE_PREFIX, vc):vcproj = 1
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment