Commit d7284b62 authored by Daniel Teske's avatar Daniel Teske

Fix importing in source build with no qt version

Before we would only offer widgets for targets which had at least
a qt version. Thus it was impossible to import a in source desktop
build if the user had no qt version for the desktop in the settings.

Change-Id: Ib8e04b1569ac3499c11c5cfda6c708f5fd408144
Reviewed-by: default avatarTobias Hunger <tobias.hunger@nokia.com>
parent 72d46620
......@@ -134,7 +134,7 @@ Qt4TargetSetupWidget *Qt4DesktopTargetFactory::createTargetSetupWidget(const QSt
minimumQtVersion,
maximumQtVersion,
requiredFeatures);
if (infos.isEmpty())
if (infos.isEmpty() && importInfos.isEmpty())
return 0;
Qt4DefaultTargetSetupWidget *widget = new Qt4DefaultTargetSetupWidget(this, id, proFilePath, infos,
minimumQtVersion, maximumQtVersion,
......
......@@ -102,7 +102,7 @@ Qt4TargetSetupWidget *Qt4BaseTargetFactory::createTargetSetupWidget(const QStrin
minimumQtVersion,
maximumQtVersion,
requiredFeatures);
if (infos.isEmpty())
if (infos.isEmpty() && importInfos.isEmpty())
return 0;
const bool supportsShadowBuilds
= targetFeatures(id).contains(QLatin1String(Constants::SHADOWBUILD_TARGETFEATURE_ID));
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment