Commit eb795149 authored by dt's avatar dt
Browse files

Qt Project Config Widget: Correctly dis/enable the Qt Version combobox

Task-Nr: QTCREATORBUG-2722
Reviewed-By: kh
parent f707cfd8
......@@ -240,12 +240,12 @@ void Qt4ProjectConfigWidget::qtVersionsChanged()
if (validVersions.at(i) == qtVersion)
m_ui->qtVersionComboBox->setCurrentIndex(i);
}
m_ui->qtVersionComboBox->setEnabled(validVersions.count() > 1);
}
if (!qtVersion->isValid()) {
m_ui->qtVersionComboBox->addItem(tr("Invalid Qt version"), -1);
m_ui->qtVersionComboBox->setCurrentIndex(m_ui->qtVersionComboBox->count() - 1);
}
m_ui->qtVersionComboBox->setEnabled(m_ui->qtVersionComboBox->count() > 1);
m_ignoreChange = false;
updateToolChainCombo();
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment